There was an error in this gadget

Monday, 6 February 2012

Skyrim Script Extender SKSE v.1.04.10 for The Elder Scrolls V: Skyrim v.1.4.21.04




Download

SKSE will support the latest version of Skyrim available on Steam, and only this version (currently 1.4.21.04). When a new version is released, we will update as soon as possible; please be patient. This is a "pre-release" version, and should be treated as such. There may be bugs, and functionality may be added or changed.

No comments:

Post a Comment